Aller au contenu
robot

Correction du bug de timeout

Publications recommandées

<p>La version 5.1.4.1 est en ligne. Elle corrige un problème qui perdurait depuis un bout de temps.</p><p> </p><ul><li>Depuis la version 3 la détection se lance dans un service système séparé du <em>plugin </em>dans le navigateur. Si le service système ne répond plus au bout d'une minute, le navigateur répond par un <em>timeout</em>.</li></ul><p> </p><p>Sur les versions récentes, suite à un changement dans le module de communication, une regression était apparue. Toutes les détections qui duraient plus d'une minute provoquaient un <em>timeout</em>. Or ce <em>timeout </em>est en fait une durée d'inactivité maximale: quand le <em>plugin </em>continue de recevoir des données pendant la détection du service système, il devrait réinitialiser le <em>timeout, </em>ce qui n'était plus le cas. </p><p>Le problème est maintenant corrigé. Je précise que le message peut continuer à se produire dans certains cas justifiés, par exemple si le service système plante. Mais ce n'est plus du bug. </p>

Partager cette publication


Lien à poster
Partager sur d’autres sites
Invité
Vous postez un commentaire en tant qu’invité. Si vous avez un compte, merci de vous connecter.
Répondre à ce sujet...

×   Collé en tant que texte riche.   Changer pour un collage en texte brut

  Seules 75 émoticônes sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher en tant que lien à la place

×   Votre contenu précédent a été restauré.   Vider l'éditeur

×   You cannot paste images directly. Upload or insert images from URL.


×