Aller au contenu
Guy77

Où sont les fichiers exécutables? - Pilotes pour Windows 10 Professionnel pour un PC industriel - Résolu

Recommended Posts

Bonjour à tous,

 

J'ai un PC "industriel" qui était sous Windows 7 Professionnel 64bits et que je viens de passer en Windows 10 (Professionnel donc). Tout s'est bien déroulé, mais comme d'habitude pour mes configurations classiques, j'ai lancé une recherche de Màj de pilotes avec la fonction Détection de DriversCloud. Là aussi, rien d'anormal, il m'a trouve quelques pilotes à mettre à jour et j'ai lancé le téléchargement.

 

Là où ça se complique, c'est que dans les fichiers décompressés, je ne trouve pas de fichier exécutable et qu'il y a pleins d'arborescences, du coup j'aurais besoin de votre aide pour y voir plus clair et identifier comment procéder. (Est-ce à cause du fait que c'est un Windows 10 Professionnels, mes autres sont des versions famille, ou est-ce parce que c'est un PC spécial...)

 

Voici quelques infos pour mieux comprendre : Le PC est un Twister avec un board CI770A/C. Voici comment il est détecté:

 

===== Détection par Ma config matérielle =====

 

Système d'exploitation :

Windows 10 Professionnel (X64) Date d'installation: 05/03/2016

 

Processeur :

Intel Core i5 3320M Cadencé à 2.60 GHz

Fréquence mesurée (core0): 1.20 GHz

Nombre de coeurs: 2 physique(s), 4 logique(s)

Socket: Socket 988B rPGA

Température CPU (core 0): 31 °C

 

Carte mère :

INTEL Corporation ChiefRiver To be filled by O.E.M.

Version du bios: 4.6.5

Date: 19/03/2014

 

Chipset :

Pont nord : Intel Ivy Bridge, Identifiant de révision: 09

Pont sud : Intel QM77, Identifiant de révision: 04

 

Mémoire : 8 Go de mémoire totale de type DDR3 à 665.11 MHz

Timings mémoire: 9.0 clocks-9 clocks-9 clocks-24 clocks-1 TT

Barrette InnoDisk Corporation de 4 Go, Fréquence maximale: 667 MHz, Bande passante: PC3-10700

Barrette InnoDisk Corporation de 4 Go, Fréquence maximale: 667 MHz, Bande passante: PC3-10700

 

Carte Graphique : Intel(R) HD Graphics 4000

Version DirectX installée: 11.0

Fréquence du GPU: 350 MHz

 

Disque dur :

Disque dur TOSHIBA TransMemory USB Device de 14.45 Go

SSD InnoLitemSATAD150Q de 119.24 Go SATA II

Firmware: 120319

Version du SATA: SATA Rev 2.6

Numéro de série: xxxxxxxxxxxx

Température HDD: 46 °C

Temps de fonctionnement: 179 heures

 

Réseau :

Intel(R) 82579LM Gigabit Network Connection

Type d'adaptateur: ethernet

 

Microsoft Wi-Fi Direct Virtual Adapter

Type d'adaptateur: IEEE 802.11 wireless

 

 

Microsoft Hosted Network Virtual Adapter

Type d'adaptateur: IEEE 802.11 wireless

 

Intel(R) 82574L Gigabit Network Connection

Type d'adaptateur: ethernet

 

Qualcomm Atheros AR5B125 Wireless Network Adapter

Type d'adaptateur: IEEE 802.11 wireless

 

Bluetooth Device (Personal Area Network)

Type d'adaptateur: ethernet

 

Software Loopback Interface 1

Type d'adaptateur: Loopback

 

Cartes multimedia

Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller

 

Clavier :

ATEN International Co., Ltd CS682 2-Port USB 2.0 DVI KVM Switch (CE700A V1.1.109)

 

Clavier standard PS/2

 Logitech, Inc. diNovo Wireless Desktop (USB Receiver)

 Logitech HID-Compliant Keyboard

 Logitech HID-Compliant Keyboard

 

Souris :

Souris Microsoft PS/2

ATEN International Co., Ltd CS682 2-Port USB 2.0 DVI KVM Switch (CE700A V1.1.109)

Logitech, Inc. diNovo Wireless Desktop (USB Receiver)

Logitech MX900 Bluetooth Optical Mouse

 

Ecran(s) :

Moniteur non Plug-and-Play générique

 

Périphérique USB

Logitech, Inc. diNovo Wireless Desktop (USB Receiver)

Version USB supportée: 1.10

 

Logitech, Inc. Bluetooth wireless hub (Logitech Bluetooth wireless hub)

Version USB supportée: 1.10

 

ATEN International Co., Ltd CS682 2-Port USB 2.0 DVI KVM Switch (CE700A V1.1.109)

Version USB supportée: 1.10

 

 

=========== Fin de la détection ===========

 

Voici les fichiers pilotes "exotiques" que je ne sais pas traiter :

Cartes  Réseaux: il trouve deux pilotes à mettre à jour (mais je ne sais pas comment faire) :

Qualcomm Atheros AR9485 Wireless Network Adapter Pilote du 19/11/2015 (WHQL) è Killer-Ethernet-Wireless_INF.zip 

Une fois décompressé, il y a une arborescence Killer-Ethernet-Wireless_INF\drivers\Production puis des répertoires Windows7 à Windows 10 en x86 et x64 (pour moi ça devrait être Windows10x-64), puis des sous-répertoires bwcw10, k11acw, k11nw10, ke2200w10 et ke2400w10… avec dedans un fichier catalogue et deux fichiers inf?...

 

Intel Corporation 82574L Gigabit Network Connection Pilote du 26/05/2015 (WHQL) è LAN_Win10_64_20.4.1.exe.

Une fois lancé, l'extraction se passe, puis j'ai un message "Bienvenue dans l'assistant d'installation de connexions réseaux Intel. Le programme d'installation de Connexion réseau Intel prépare l'assistant d'installation qui vous guidera tout au long du processus d'installation". Puis j'ai un pop up : Information sur l'installation de Connexions réseau Intel. "La version installée de Connexion réseau Intel ne peut pas être mise à niveau. Elle doit être désinstallée avant que cette version soit installée." J'ai un programme Intel Network Connections 14.8.43.0. Est-ce celui là qu'il faut désinstaller?... 

 

Cartes PCI : il trouve un pilote à mettre à jour (mais je ne sais pas comment faire) :

Intel Corporation 7 Series/C210 Series Chipset Family KT Controller Pilote du 08/05/2015 (WHQL) è ME_Win10_5.0M_11.0.0.1158.zip   

Une fois décompressé, il y a une arborescence de répertoires : ME_Win10_5.0M_11.0.0.1158\Intel(R)_ME_11.0_Corporate_11.0.0.1158_SW_Only\Installers, puis au même niveau : ME_SW_MSI, MEI-Only Installer MSI et WINDOWSDriverPackages. Dans ME_SW_MSI, j'ai un répertoire Production avec un fichier SetupME, une dll et un fichier XML (là, le setup je saurais quoi en faire…). Dans MEI-Only Installer MSI, J'ai un fichier MESetup, une fichier dll, un fichier XML et un document texte. Enfin dans WINDOWSDriverPackages, j'ai un répertoire MEI avec un fichier heci.cat, un fichier heci.inf et trois répertoires qui s'appelle respectivement Symbols, x64 et x86. Dans le répertoire SOL, j'ai un fichier mesrl.cat et un fichier mesrl.inf

 

 

Voilà, j'espère avoir été clair, n'hésitez pas à me poser des questions si vous voulez que je précise un point.

 

A+

Guy

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir,

Citation

Cartes  Réseaux: il trouve deux pilotes à mettre à jour (mais je ne sais pas comment faire) :

Qualcomm Atheros AR9485 Wireless Network Adapter Pilote du 19/11/2015 (WHQL) è Killer-Ethernet-Wireless_INF.zip 

Une fois décompressé, il y a une arborescence Killer-Ethernet-Wireless_INF\drivers\Production puis des répertoires Windows7 à Windows 10 en x86 et x64 (pour moi ça devrait être Windows10x-64), puis des sous-répertoires bwcw10, k11acw, k11nw10, ke2200w10 et ke2400w10… avec dedans un fichier catalogue et deux fichiers inf?...

Lorsqu'un pilote n'intègre pas de fichier d'installation automatique (.EXE), celui-ci s'installe manuellement par le "Gestionnaire de périphériques".

Voici un tuto expliquant la marche à suivre:

Mode d'emploi de DriversCloud.com/Installer ses pilotes

 

Citation

Intel Corporation 82574L Gigabit Network Connection Pilote du 26/05/2015 (WHQL) è LAN_Win10_64_20.4.1.exe.

Une fois lancé, l'extraction se passe, puis j'ai un message "Bienvenue dans l'assistant d'installation de connexions réseaux Intel. Le programme d'installation de Connexion réseau Intel prépare l'assistant d'installation qui vous guidera tout au long du processus d'installation". Puis j'ai un pop up : Information sur l'installation de Connexions réseau Intel. "La version installée de Connexion réseau Intel ne peut pas être mise à niveau. Elle doit être désinstallée avant que cette version soit installée." J'ai un programme Intel Network Connections 14.8.43.0. Est-ce celui là qu'il faut désinstaller?... 

 

Oui c'est bien celui-ci.

 

Citation

Cartes PCI : il trouve un pilote à mettre à jour (mais je ne sais pas comment faire) :

Intel Corporation 7 Series/C210 Series Chipset Family KT Controller Pilote du 08/05/2015 (WHQL) è ME_Win10_5.0M_11.0.0.1158.zip   

Une fois décompressé, il y a une arborescence de répertoires : ME_Win10_5.0M_11.0.0.1158\Intel(R)_ME_11.0_Corporate_11.0.0.1158_SW_Only\Installers, puis au même niveau : ME_SW_MSI, MEI-Only Installer MSI et WINDOWSDriverPackages. Dans ME_SW_MSI, j'ai un répertoire Production avec un fichier SetupME, une dll et un fichier XML (là, le setup je saurais quoi en faire…). Dans MEI-Only Installer MSI, J'ai un fichier MESetup, une fichier dll, un fichier XML et un document texte. Enfin dans WINDOWSDriverPackages, j'ai un répertoire MEI avec un fichier heci.cat, un fichier heci.inf et trois répertoires qui s'appelle respectivement Symbols, x64 et x86. Dans le répertoire SOL, j'ai un fichier mesrl.cat et un fichier mesrl.inf

 

Ce package regroupe 2 pilotes: MEI et SOL KT.

Dans ton cas, il faut installer le pilote SOL KT (d'où la référence du périphérique "KT Controller").

Pour cela lance le fichier d'installation automatique SetupMe.exe dans le dossier ME_SW_MSI/Production. Il est destiné aux deux pilotes (MEI et SOL KT).

Le fichier MESetup.exe du dossier MEI-Only Installer MSI, comme son nom l'indique, est uniquement destiné au pilote MEI.

Quand au dossier WINDOWSDriverPackages, il est seulement destiné à une installation manuelle par le "Gestionnaire de périphériques".

 

 

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour Sébastien,

 

Comme promis je reviens vers toi pour te tenir informé:

J'avais 3 pilotes à mettre à jour :

1) Une carte réseau Qualcomm Atheros AR9485 Wireless Network Adapter Pilote du 19/11/2015 (WHQL) è Killer-Ethernet-Wireless_INF.zip. Pour celui-ci pas de problème, j'ai trouvé la carte dans le Gestionnaire de périphériques et j'ai descendu l'arborescence jusqu'à sélectionner le répertoire Windows10-x64 et il a fait la mise à jour.

J'ai relancé la détection de DriversCloud derrière et celle ligne avait disparu.

 

Pour les 2 suivants je patauge un peu... Voici ce que j'ai pour chacun et le problème que je rencontre :

2) Une carte réseau Intel Corporation 82574L Gigabit Network Connection Pilote du 26/05/2015 (WHQL) è LAN_Win10_64_20.4.1.exe. Pour celui-ci pas de problèmes au niveau du Gestionnaire de périphériques, la carte est facilement identifiable, mais c'est au niveau de l'arborescence du driver que ça se complique :  Lorsque je décompresse le fichier LAN_Win10_64_20.4.1.exe j'ai pas mal d'arborescence et dans le pointage de l'emplacement je ne trouve pas la logique pour choisir le répertoire. J'ai les répertoires et sous répertoires suivants:

APPS avec les sous répertoires : PROSETDX, SETUP(SETUPBD), SNMP(MIB), TOOLS   

PLATFORM avec le sous répertoire IOATDMA

PRO40GB

PRO100

PRO1000

PROXGB

Ils ont pour la plupart des sous-répertoires Win10_x64 ou Winx64.

 

Lorsqu'on est dans le Gestionnaire de périphériques dans "Mettre à niveau le pilote" et qu'on choisi "Rechercher un pilote sur mon ordinateur", on peut cocher "Inclure les sous répertoires", c'est ce que je fais, mais je suppose qu'il faut avancer dans l'arborescence pour choisir la branche qui correspond au pilote qu'on veut mettre à jour, non?

Dans la détection, je vois que le pilote que la détection a identifié comme obsolète est le 82574L Gigabit Network Connection version 12.12.50.6 du 20/03/2015. Le pilote qu'il a identifié est le LAN_Win10_64_20.4.1.exe (un package comme on a vu que j'ai décompressé), dont la version est 12.7.28.0 du 26/05/2015 (la date est plus ancienne, mais je lui fait confiance...), par contre est-ce qu'il suffirait de pointer sur le niveau le plus haut de l'arborescence décompressée et de le laisser se débrouiller seul?...

3) Une carte PCI Intel Corporation 7 Series/C210 Series Chipset Family KT Controller Pilote du 08/05/2015 (WHQL) è ME_Win10_5.0M_11.0.0.1158.zip Pour celui-ci ça se complique encore un peu plus parce que je ne vois pas à quoi correspond cette carte dans le Gestionnaire de périphériques... Dans Périphériques système, je trouve bien plusieurs lignes "Intel 7 Series/C216 Chipset Family PCI Express Root Port x", est-ce une de celles là?

Dans la détection, je vois que le pilote que la détection a identifié comme obsolète est le 7 Series/C210 Series Chipset Family KT Controller version 8.1.0.1252 du 25/06/2012. Le pilote qu'il a identifié est le ME_Win10_5.0M_11.0.0.1158.zip (un autre package que j'ai décompressé), dont la version est 11.0.0.1136 du 08/05/2015. Ce coup ci par de question sur la date, celui proposé est plus récent. 

 

Enfin lorsque je regarde l'arborescence ME_Win10_5.0M_11.0.0.1158, là j'ai un peu de tout, voici les répertoires :

Intel(R)_ME_11.0_Corporate_11.0.0.1158_SW_Only, puis un sous répertoire "Installers" et trois répertoires au dessous :

ME_SW_MSI (Production)

MEI_Only Installer MSI

WINDOWSDriverPackages (MEI, Symbols, x64, etc...) (SOL) 

 

Je coince un peu la dessus... Pourrais-tu m'éclairer?

 

Merci!

 

Guy

Partager ce message


Lien à poster
Partager sur d’autres sites
Citation

2) Une carte réseau Intel Corporation 82574L Gigabit Network Connection Pilote du 26/05/2015 (WHQL) è LAN_Win10_64_20.4.1.exe. Pour celui-ci pas de problèmes au niveau du Gestionnaire de périphériques, la carte est facilement identifiable, mais c'est au niveau de l'arborescence du driver que ça se complique :  Lorsque je décompresse le fichier LAN_Win10_64_20.4.1.exe j'ai pas mal d'arborescence et dans le pointage de l'emplacement je ne trouve pas la logique pour choisir le répertoire. J'ai les répertoires et sous répertoires suivants:

Tu n'es pas obligé d'indiquer un sous-dossier en particulier, tu indiques le dossier lui-même tout simplement.

Après tu n'étais pas obligé non plus de le décompresser, il suffit de lancer le fichier .EXE, pour que celui-ci se décompresse (dans le dossier Temp) et s'installe automatiquement.

 

Citation

Lorsqu'on est dans le Gestionnaire de périphériques dans "Mettre à niveau le pilote" et qu'on choisi "Rechercher un pilote sur mon ordinateur", on peut cocher "Inclure les sous répertoires", c'est ce que je fais, mais je suppose qu'il faut avancer dans l'arborescence pour choisir la branche qui correspond au pilote qu'on veut mettre à jour, non?

La case "Inclure les sous-dossiers" est déjà cochée par défaut.

Comme indiqué plus haut, il suffit de sélectionner uniquement le dossier et non un sous-dossier en particulier.

 

Citation

3) Une carte PCI Intel Corporation 7 Series/C210 Series Chipset Family KT Controller Pilote du 08/05/2015 (WHQL) è ME_Win10_5.0M_11.0.0.1158.zip Pour celui-ci ça se complique encore un peu plus parce que je ne vois pas à quoi correspond cette carte dans le Gestionnaire de périphériques... Dans Périphériques système, je trouve bien plusieurs lignes "Intel 7 Series/C216 Chipset Family PCI Express Root Port x", est-ce une de celles là?

Il s'agit du périphérique Intel(R) Active Management Technology à la catégorie Périphériques système.

 

Citation

Enfin lorsque je regarde l'arborescence ME_Win10_5.0M_11.0.0.1158, là j'ai un peu de tout, voici les répertoires :

Intel(R)_ME_11.0_Corporate_11.0.0.1158_SW_Only, puis un sous répertoire "Installers" et trois répertoires au dessous :

ME_SW_MSI (Production)

MEI_Only Installer MSI

WINDOWSDriverPackages (MEI, Symbols, x64, etc...) (SOL) 

Je t'ai déjà répondu, je me cite:

Citation

Ce package regroupe 2 pilotes: MEI et SOL KT.

Dans ton cas, il faut installer le pilote SOL KT (d'où la référence du périphérique "KT Controller").

Pour cela lance le fichier d'installation automatique SetupMe.exe dans le dossier ME_SW_MSI/Production. Il est destiné aux deux pilotes (MEI et SOL KT).

Le fichier MESetup.exe du dossier MEI-Only Installer MSI, comme son nom l'indique, est uniquement destiné au pilote MEI.

Quand au dossier WINDOWSDriverPackages, il est seulement destiné à une installation manuelle par le "Gestionnaire de périphériques".

Pour une installation automatique, lance le fichier SetupMe.exe dans le sous-dossier ME_SW_MSI/Production.

Pour une installation manuelle, sélectionne le dossier décompressé ME_Win10_5.0M_11.0.0.1158.

 

En résumé lors d'une installation manuelle, il suffit seulement de pointer vers le dossier décompressé.

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites

  Bonjour Sébastien,

Merci pour ta réponse, j'ai enfin eu un peu de temps pour avancer et mettre en pratique tes conseils!

Voilà où j'en suis:

Pour la carte PCI, c'est réglé, j'ai lancé le fichier SetupMe.exe dans le sous-dossier ME_SW_MSI/Production. J'ai vérifié en lançant une nouvelle détection et il n'y a plus de Màj pour cette carte.

Pour les cartes réseaux, c'est réglé pour la carte Qualcomm Atheros AR9485 Wireless Network Adapter, par contre, pour la carte Intel Corporation 82574L Gigabit Network Connection il reste un peu de travail à faire :

Une nouvelle carte est apparue a mettre à jour, c'est la carte Intel Corporation 82579LM Gigabit Network Connection Pilote du 12/11/2015 (WHQL) et le fichier de Màj associé est le LAN_Win10_64_20.7, j'ai fait la Màj sans problèmes et cette Màj à faire n'a plus été détectée.

Ensuite je suis passé à l'autre carte Réseau Intel dont je t'avais parlé (Intel Corporation 82574L Gigabit Network Connection Pilote du 26/05/2015 (WHQL) et le fichier de Màj associé est le LAN_Win10_64_20.4.1.exe) : J'ai désinstallé le programme Intel Network Connections 14.8.43.0 et j'ai lancé l'installation. Là j'ai un message qui me dit " Une version plus récente de Connexion réseau Intel est déjà installée sur cet ordinateur. Avant d'utiliser ce programme d'installation, vous devez supprimer la version actuelle de Connexion réseau Intel". J'ai regardé dans les programmes installés et le seul qui ressemble à ça maintenant est le Intel Network Connections 20.7.67.0. Ce coup-ci, je ne vois plus trop l'intérêt de désinstaller ce programme puisqu'il semble plus récent... mais dans ce cas pourquoi est-ce que j'ai une détection de pilote à mettre à jour?...

Pour rappel, dans le gestionnaire de périphériques j'ai les cartes et les pilotes suivants:

Intel 82574L Gigabit Network Connexion #2     Pilote : 12.12.50.6 du 20/03/2015

Intel 82579LM Gigabit Network Connexion       Pilote : 12.15.31.0 du 12/11/2015

Qualcomm Atheros AR5B125 Wireless Network Adapter      Pilote : 10.0.0.329 du 19/11/2015

Pour info si je fais une recherche de Màj du pilote de chacune de ces cartes dans le Gestionnaire de périphériques, Windows me dit que j'ai le meilleur pilote installé et Windows Update ne signale rien. Seul DriversCloud signale cette Màj.

(je t'attache une copie d'écran de l'écran de Màj)

 

A+

Guy

 

Modifié par Guy77
Suppression pièce jointe

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

Citation

Ce coup-ci, je ne vois plus trop l'intérêt de désinstaller ce programme puisqu'il semble plus récent... mais dans ce cas pourquoi est-ce que j'ai une détection de pilote à mettre à jour?...

La détection automatique se base sur la date du fichier INF, ignore-là, tous tes pilotes sont bien à jour.

 

 

 

 

  • Like 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour Sébastien,

Super! Enfin une config à jour (pas sûr que ça dure, mais au moins je saurai refaire ces étapes lorsqu'il y aura de nouvelles mises à jour)

Merci beaucoup pour ton temps, je marque ce post comme résolu

Guy 

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

×