Aller au contenu
robot

Version 8: Vers une application

Publications recommandées

Depuis vendredi soir une nouvelle version majeure du programme Ma-Config.com a été mise en ligne. Historiquement Ma-Config.com tournait avec les technologies ActiveX et NPAPI. Elles permettaient d'intégrer totalement la détection du PC dans le navigateur web. Depuis quelques années cette technologie était condamnée pour finalement disparaître avec le remplaçant d'Internet Explorer: Microsoft Edge sur Windows 10. J'avais anticipé cette décision il y a plus de deux ans avec la version 7 du programme Ma-Config.com. Cette version 7 intégrait un serveur websocket en local dans un service système qui communiquait avec le navigateur web. Mais hélas avec les dernières versions d'Internet Explorer sur Windows 8 les communications réseaux locales avec le navigateur web se sont retrouvées bloquées. J'ai appliqué temporairement certaines astuces mais elles ne marchaient plus sur Microsoft Edge. Des changements importants sur le fonctionnement de Ma-Config.com étaient nécessaires.

La version 8 apporte une solution durable. Nous avons décidé de basculer entièrement la détection sur une application. Le service système Ma-Config.com a été supprimé. Les versions antérieures intégraient déjà une application mais ne marchaient pas avec toutes les fonctionnalités du site web.

La principale fonction est de pouvoir se connecter par authentification OAuth sur le compte Ma-Config.com de l'application. Une fois connecté, l'application peut récupérer les paramètres du compte Ma-Config.com. Le centre de paramétrage ne nécessite plus de communication directe avec l'application. Les options spécifiques au programme Ma-Config.com comme la gestion des modules nécessitent un compte Ma-Config.com. En non connectée l'application est toujours utilisable mais le programme s'exécutera avec les options par défaut. Pour rappel nous avons fait une refonte du système de comptes utilisateurs récemment. Il est désormais beaucoup plus simple de créer un compte et se connecter.

Pour ne pas casser l'ancienne expérience utilisateur, il est toujours possible de lancer du site l'application du site par un "Url Protocol Handler". Mais celà reste optionnel. Si l'application est connectée sur le compte Ma-Config.com vous serez connecté automatiquement sur le site web. De même l'inverse est aussi vrai si vous lancez l'application du site web.

Depuis deux mois Google nous bloquait nos installeurs sans donner aucune explication. Temporairement j'avais mis à disposition la version zippée du programme Ma-Config.com. Bonne nouvelle pour la version 8 je viens de remettre en ligne les versions avec installeur.

  • Like 2

Partager cette publication


Lien à poster
Partager sur d’autres sites

J'ai corrigé :

*un problème d'échec d'envoi au serveur à la fin de la détection

*Lors de la connexion au compte,une connection sur un mauvais compte du forum pouvait intervenir

*Initialisation correcte du fuseau horaire par défaut sur Paris.

Partager cette publication


Lien à poster
Partager sur d’autres sites

Bonjour

 

Depuis que j'ai réinstallé windows (8.1) sur mon PC je reçois le message échec de l'envoi au serveur.........j'utilise maconfig depuis des années et je n'ai jamais eu aucun problème........j'ai essayé de configurer mon pare feu mais rien à faire, j'ai momentanément désactivé ce dernier et l'antivirus mais sans résultat................

Que faire.

Merci 

Partager cette publication


Lien à poster
Partager sur d’autres sites

Merci mais oui tout est à jour, je suis sur Chrome mais j'ai aussi essayé avec internet explorer mais sans plus de succès...................je pense que c'est windows qui ne tourne plus rond en ce moment et je vais tout remettre à zéro. je vous tiens au courant.

Encore merci

Partager cette publication


Lien à poster
Partager sur d’autres sites

Bonjour ;)

en fait je ne parlais pas de ceci:

Aller dans le panneau de configuration options internet: onglet connexion: parametres réseaux:

Verfiier en bas que la case serveur proxy est bien décoché.

 

De plus il semble avoir des ennuis avec l'installeur. Désinstallez complètement ma-config.com et réinstallez le.

Partager cette publication


Lien à poster
Partager sur d’autres sites

Bonjour,
 
Impossible d'installer la version 8.0.0.4 sous Win 10, même après désinstall de la 8.0.0.3..., et même en mode Admin

 

Message : "impossible d'ouvrir ce package d'installation. Vérifiez qu'il existe et que vous êtes autorisés à y accéder, ou vérifiez auprès de votre revendeur d'applications que ce package est valide".
 
Faut-il désactiver Smartscreen ?
 
Cordialement

Partager cette publication


Lien à poster
Partager sur d’autres sites

Bonjour ;)

suite au passage sur Windows 10 le msi de ma-config.com dans le cache a du être supprimé ou endommagé, ce qui explique cette  erreur.

Va lire la faq et suis le point 2:

http://www.forum.ma-config.com/index.php?showtopic=1146

 

Ensuite réinstalle ma-config.com

Partager cette publication


Lien à poster
Partager sur d’autres sites

Bonsoir et merci de ta réponse, après désinstall de la 8.0.0.3 j'ai téléchargé la nouvelle version et l'ai réinstallée en décochant le mode silencieux : miracle et mystère de l'informatique, l'install s'est déroulée impeccablement !!!

 

Bien cordialement

Partager cette publication


Lien à poster
Partager sur d’autres sites
Invité
Vous postez un commentaire en tant qu’invité. Si vous avez un compte, merci de vous connecter.
Répondre à ce sujet...

×   Collé en tant que texte riche.   Changer pour un collage en texte brut

  Seules 75 émoticônes sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher en tant que lien à la place

×   Votre contenu précédent a été restauré.   Vider l'éditeur

×   You cannot paste images directly. Upload or insert images from URL.


×