Aller au contenu
paulmarie

[Ubuntu] Installation impossible (.deb) dépendance "Libboost"

Recommended Posts

Bonjour,

Je viens de passer à Linux et j'ai besoin de mon pilote graphique (dont je ne connais pas la référence). J'ai donc téléchargé la version 32 bits du fichier (.deb). J'essaie de l'installer avec la Logitech Ubuntu et j'ai le message suivant:

La dépendance ne peut être satisfaisante: libboost-system1.49.0

Quand j'utilise le Terminal avec dpkg -i

paul@Paul-Ubuntu:~/Téléchargements$ sudo dpkg -i MaConfig_Linux_7_0_2_1.debSélection du paquet ma-config.com précédemment désélectionné.(Lecture de la base de données... 210900 fichiers et répertoires déjà installés.)Dépaquetage de ma-config.com (à partir de MaConfig_Linux_7_0_2_1.deb) ...dpkg : des problèmes de dépendances empêchent la configuration de ma-config.com : ma-config.com dépend de libboost-system1.49.0 ; cependant :  Le paquet libboost-system1.49.0 n'est pas installé. ma-config.com dépend de libboost-thread1.49.0 ; cependant :  Le paquet libboost-thread1.49.0 n'est pas installé. ma-config.com dépend de libboost-regex1.49.0 ; cependant :  Le paquet libboost-regex1.49.0 n'est pas installé.dpkg : erreur de traitement de ma-config.com (--install) : problèmes de dépendances - laissé non configuréTraitement des actions différées (« triggers ») pour « ureadahead »...ureadahead will be reprofiled on next rebootDes erreurs ont été rencontrées pendant l'exécution : ma-config.com

J'ai essayé de faire apt-get install -f mais cela ne change rien.

Voici les résultats pour Libboost:

 

maconfig.png

 

Après les avoir tous installés, le paquet est toujours impossible à installer.

Les versions 1.49.0 respectives n'existent pas.

 

aptitude search libboost:

paul@Paul-Ubuntu:~/Téléchargements$ aptitude search libboostp   libboost-all-dev                - Boost C++ Libraries development files (ALLp   libboost-chrono1.48-dev         - C++ representation of time duration, time p   libboost-chrono1.48.0           - C++ representation of time duration, time p   libboost-date-time-dev          - date-time libraries based on generic progri A libboost-date-time1.46-dev      - set of date-time libraries based on generii A libboost-date-time1.46.1        - set of date-time libraries based on generip   libboost-date-time1.48-dev      - set of date-time libraries based on generip   libboost-date-time1.48.0        - set of date-time libraries based on generip   libboost-dbg                    - Bibliothèques Boost C++ avec symboles de dp   libboost-dev                    - Boost C++ Libraries development files (defp   libboost-doc                    - Boost C++ Libraries documentation (defaultp   libboost-filesystem-dev         - filesystem operations in C++ (default versp   libboost-filesystem1.46-dev     - filesystem operations (portable paths, itep   libboost-filesystem1.46.1       - filesystem operations (portable paths, itep   libboost-filesystem1.48-dev     - filesystem operations (portable paths, itep   libboost-filesystem1.48.0       - filesystem operations (portable paths, itep   libboost-graph-dev              - generic graph components and algorithms inp   libboost-graph-parallel-dev     - generic graph components and algorithms inp   libboost-graph-parallel1.46-dev - generic graph components and algorithms inp   libboost-graph-parallel1.46.1   - generic graph components and algorithms inp   libboost-graph-parallel1.48-dev - generic graph components and algorithms inp   libboost-graph-parallel1.48.0   - generic graph components and algorithms inp   libboost-graph1.46-dev          - generic graph components and algorithms inp   libboost-graph1.46.1            - generic graph components and algorithms inp   libboost-graph1.48-dev          - generic graph components and algorithms inp   libboost-graph1.48.0            - generic graph components and algorithms inp   libboost-iostreams-dev          - Boost.Iostreams Library development files p   libboost-iostreams1.46-dev      - Boost.Iostreams Library development files i A libboost-iostreams1.46.1        - bibliothèque Boost.Iostreams              p   libboost-iostreams1.48-dev      - Boost.Iostreams Library development files p   libboost-iostreams1.48.0        - Boost.Iostreams Library                   p   libboost-locale1.48-dev         - C++ facilities for localization           p   libboost-locale1.48.0           - C++ facilities for localization           p   libboost-math-dev               - Boost.Math Library development files (defap   libboost-math1.46-dev           - Boost.Math Library development files      p   libboost-math1.46.1             - Boost.Math Library                        p   libboost-math1.48-dev           - Boost.Math Library development files      p   libboost-math1.48.0             - Boost.Math Library                        p   libboost-mpi-dev                - C++ interface to the Message Passing Interp   libboost-mpi-python-dev         - Python interface to the Message Passing Inp   libboost-mpi-python1.46-dev     - C++ interface to the Message Passing Interp   libboost-mpi-python1.46.1       - C++ interface to the Message Passing Interp   libboost-mpi-python1.48-dev     - C++ interface to the Message Passing Interp   libboost-mpi-python1.48.0       - C++ interface to the Message Passing Interp   libboost-mpi1.46-dev            - C++ interface to the Message Passing Interp   libboost-mpi1.46.1              - C++ interface to the Message Passing Interp   libboost-mpi1.48-dev            - C++ interface to the Message Passing Interp   libboost-mpi1.48.0              - C++ interface to the Message Passing Interp   libboost-program-options-dev    - program options library for C++ (default vp   libboost-program-options1.46-de - program options library for C++           p   libboost-program-options1.46.1  - program options library for C++           p   libboost-program-options1.48-de - program options library for C++           p   libboost-program-options1.48.0  - program options library for C++           p   libboost-python-dev             - Boost.Python Library development files (dep   libboost-python1.46-dev         - Boost.Python Library development files    p   libboost-python1.46.1           - Boost.Python Library                      p   libboost-python1.48-dev         - Boost.Python Library development files    p   libboost-python1.48.0           - Boost.Python Library                      p   libboost-random-dev             - Boost Random Number Library (default versip   libboost-random1.46-dev         - Boost Random Number Library               p   libboost-random1.46.1           - Boost Random Number Library               p   libboost-random1.48-dev         - Boost Random Number Library               p   libboost-random1.48.0           - Boost Random Number Library               p   libboost-regex-dev              - regular expression library for C++ (defaulp   libboost-regex1.46-dev          - Bibliothèque d'expressions rationnelles pop   libboost-regex1.46.1            - Bibliothèque d'expressions rationnelles pop   libboost-regex1.48-dev          - regular expression library for C++        i   libboost-regex1.48.0            - regular expression library for C++        p   libboost-serialization-dev      - serialization library for C++ (default veri A libboost-serialization1.46-dev  - serialization library for C++             i   libboost-serialization1.46.1    - serialization library for C++             p   libboost-serialization1.48-dev  - serialization library for C++             p   libboost-serialization1.48.0    - serialization library for C++             p   libboost-signals-dev            - managed signals and slots library for C++ p   libboost-signals1.46-dev        - managed signals and slots library for C++ p   libboost-signals1.46.1          - managed signals and slots library for C++ p   libboost-signals1.48-dev        - managed signals and slots library for C++ p   libboost-signals1.48.0          - managed signals and slots library for C++ p   libboost-system-dev             - Operating system (e.g. diagnostics supportp   libboost-system1.46-dev         - Operating system (e.g. diagnostics supportc   libboost-system1.46.1           - Operating system (e.g. diagnostics supportp   libboost-system1.48-dev         - Operating system (e.g. diagnostics supportp   libboost-system1.48.0           - Operating system (e.g. diagnostics supportp   libboost-test-dev               - components for writing and executing test p   libboost-test1.46-dev           - components for writing and executing test p   libboost-test1.46.1             - components for writing and executing test p   libboost-test1.48-dev           - components for writing and executing test p   libboost-test1.48.0             - components for writing and executing test i   libboost-thread-dev             - portable C++ multi-threading (default versi A libboost-thread1.46-dev         - portable C++ multi-threading              i A libboost-thread1.46.1           - portable C++ multi-threading              p   libboost-thread1.48-dev         - portable C++ multi-threading              c   libboost-thread1.48.0           - portable C++ multi-threading              p   libboost-timer1.48-dev          - C++ wall clock and CPU process timers     p   libboost-timer1.48.0            - C++ wall clock and CPU process timers     p   libboost-wave-dev               - C99/C++ preprocessor library (default versp   libboost-wave1.46-dev           - C99/C++ preprocessor library              p   libboost-wave1.46.1             - C99/C++ preprocessor library              p   libboost-wave1.48-dev           - C99/C++ preprocessor library              p   libboost-wave1.48.0             - C99/C++ preprocessor library              p   libboost1.46-all-dev            - Boost C++ Libraries development files (ALLp   libboost1.46-dbg                - Bibliothèques Boost C++ avec symboles de di A libboost1.46-dev                - Fichiers de développement pour les bibliotp   libboost1.46-doc                - Documentation de la bibliothèque Boost.orgp   libboost1.48-all-dev            - Boost C++ Libraries development files (ALLp   libboost1.48-dbg                - Boost C++ Libraries with debug symbols    p   libboost1.48-dev                - Boost C++ Libraries development files     p   libboost1.48-doc                - Boost.org libraries documentation 

Paul.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour paul, tu utilises quelle version d'ubuntu.

Sinon si tu veux installer un driver, le service MesDrivers ne supporte pas Linux. 

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

Je souhaite surtout savoir ce qui se trouve dans mon ordi :Forum74:

Voici les infos détaillées:

Linux version 3.2.0-51-generic-pae (buildd@komainu) (gcc version 4.6.3 (Ubuntu/Linaro 4.6.3-1ubuntu5) ) #77-Ubuntu SMP Wed Jul 24 20:40:32 UTC 2013

Paul.

Partager ce message


Lien à poster
Partager sur d’autres sites

Il y avait un petit problème avec les paquets il manquait un fichier. Commencez par désinstaller le paquet ma-config.com avec l'interface par défaut. Puis retéléchargez  le debian 32 bits et installez le en double cliquant dessus.

Les outils comme dpkg n'installent pas les dépendances.

Partager ce message


Lien à poster
Partager sur d’autres sites

Je viens effectivement de mettre à jour le noyau mais ça ne change rien du tout (c'était prévisible). Le paquet Libboost-system 1.49 n'existe pas sur les dépots officiels.

(Par rapport à votre liens, pas besoin de réinstaller Ubuntu en entier, une mise à jour du noyau et de grub suffit, je n'allais quand-même pas réinstaller mon PC... Vous n'avez pas l'air de trop connaitre Linux :Feu30: )

Partager ce message


Lien à poster
Partager sur d’autres sites

Vous avez mal compris mon message je ne vous ai pas demande de changer le noyau. Je parlais du noyau car la commande uname ne donne pas le nom du système mais la version du noyau. Sur la dernière distribution ubuntu que j'ai testé elle intègre un noyau 3.8. Vous avez un noyau 3.2. ce qui me faisait dire que vous utilisiez une distribution plus ancienne. Installez le noyau ne changera rien il faut mettre à jour votre distribution sur une plus récente. Tout un tas de paquets sont trop anciens et vos dépôts ne proposent pas boost 1.49 car il doit dépendre de tout un tas d'autres paquets plus récents. Seule une mise à jour de la distribution réglerait le problème.

Pour linux j'en installe depuis les années 90 si je connaissais pas un minimum le fonctionnement je n'aurai pas pu écrire une version de l'agent Ma-Config sur Linux. Après je préfère de loin utiliser Windows.

Partager ce message


Lien à poster
Partager sur d’autres sites

Re,

J'ai sans doutes mal compris, cependant je ne peux pas mettre à jour mon ordinateur pour des raisons évidentes. Pourtant je l'ai installé avec un CD que j'ai gravé il y a quelques mois, étrange :)

 

Paul.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour, je vais voir si je peux pas utiliser la version 1.48 de boost à la place. Apparemment elle est disponible sur votre distribution.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

essaye d'installer ce paquet debian. J'ai viré les dépendances à boost dans le paquet. Je pense que linux devrait résoudre sur la bonne version tout seul mais j'en suis pas sur. Je te laisse essayer

7.0.3.0 .deb

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

×