Aller au contenu
Mandorol

BSOD athr.sys

Recommended Posts

Bonjour à tous,

Depuis samedi j'ai des BSOD au démarrage de ma session avec comme indication "athr.sys page_fault_in_nonpaged_area".

Samedi ce problème a fait griller ma mémoire RAM, alors obligé d'aller voir un réparateur.

Cet aprem je le récupère, je le vois bien fonctionner chez le réparateur. Je le ramène chez moi... Paf ! BSOD avec athr.sys...

Je vais voir sur internet et je suis ce qui est indiqué sur certains forums, à savoir que ça viendrait du driver Atheros Wireless. Donc je le démarre en mode sans échec et réinstalle la version antérieure du driver. Le pc démarre et tout fonctionne nickel ! J'ai réinstallé la version la plus récente du driver.

Mais j'ai peur de le redémarrer désormais !

Pourriez-vous m'indiquer la démarche à suivre pour être sûr que le problème est résolu ?

Voici le lien vers ma config:

http://www.ma-config.com/fr/configurationpubliee/128684-0-1_resume.html

J'ai fais une analyse BSOD et il y a beaucoup beaucoup de choses qui sont affichées sur la page ma-config. Il y a en tout cas une inscription rouge qui est :

Informations générales

Bug Check Code 0x00000050

Bug Check String PAGE_FAULT_IN_NONPAGED_AREA

Paramètre 1 0x83395627

Paramètre 3 0x00000000

Paramètre 3 0x8DAEEA5E

Paramètre 4 0x00000000

Date du crash 31/10/2012 18:17

Architecture x86

Version majeure 15

Version mineure 6002

Nombre de processeurs 2

Taille du fichier dump 128 Ko

Source du crash

Source du crash athr.sys+60A5E

Chemin C:\Windows\system32\athr.sys

Description Atheros Extensible Wireless LAN device driver

Version 7.7.0.449

Compagnie Atheros Communications, Inc.

Taille 1.15 Mo

Je vous remercie pour votre aide !

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour, si ça replante tu peux démarrer en mode sans echec comme tu as fait et remettre un autre driver. Le mode sans echec(pas celui en réseau) ne charge pas le wifi.

Partager ce message


Lien à poster
Partager sur d’autres sites

Juste la version du driver qui a planté c'est:

Version 7.7.0.449

d'après mesdrivers la version que tu as actuellement c'est 7.7.0.498

Celle proposé par mesdrivers c'est 9.2.0.504

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour à toi et merci pour tes réponses !

Le problème c'est que mesdrivers me propose 2 drivers à télécharger :

Cartes réseaux

Atheros Communications Inc. Atheros AR5B91 Wireless Network Adapter

Qualcomm Atheros AR1xxx/AR2xxx/AR5xxx/AR9xxx

Date du fichier INF 11/06/2012

Version du pilote 9.2.0.504 WHQL

download-btn-ico.pngTélécharger

Via Technologies VNT9285

Date du fichier INF 27/04/2010

Version du pilote 7.7.0.498 WHQL

download-btn-ico.pngTélécharger

Le premier correspond au driver: Atheros Communications Inc. AR8121/AR8113/AR8114 Gigabit or Fast Ethernet Type d'adaptateur : ethernet. Celui-ci j'arrive à le mettre à jour.

Mais j'ai un 2ème driver: Atheros Communications Inc. AR928X Wireless Network Adapter (PCI-Express) Type d'adaptateur : Unknown Bande passante : 54 Mbits/s ! Ci je mets à jour celui-ci via la mise à jour de windows, il me met la version 7.7.0.498 qui faisait planter mon PC (celle proposée au dessus). Si j'essaye d'installer l'autre driver (donc le Qualcomm Atheros AR1xxx ...), rien ne se produit (enfin plus exactement, il me dit que mon driver est déjà à jour) ! Donc pour l'instant j'ai annulé la mise à jour et installé une version précédente, mais je ne sais pas quoi faire d'autre !

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour, il ne faut pas installer tout les drivers sur un matos mais juste le plus récent. C'est trié par matériel et les drivers par date pour chaque matériel.. Tu dois installer uniquement le plus récent.

Partager ce message


Lien à poster
Partager sur d’autres sites

c'est drole parce que exemple pour une carte graphique nvidia quadro 4000, il propose aussi des drivers de nvidia geforce alors que se n'est vraiment pas la meme sorte de carte graphique le calcul en arrière est effectuer totalement différament,

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour acrogs, Mes Drivers se base sur les fichiers inf dans les drivers. C'est probable que ce driver soit en réalité compatible mais il n'est pas forcément adapté.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour à tous les 2 et désolé de répondre si tard !

E fait je me suis mal exprimé la dernière fois, j'ai 2 drivers sur mon PC qui servent à 2 choses différentes :

20121120183328.jpg

Sur cette image, il y a les 2 drivers Atheros:

-le "Atheros AR5B91" qui me pose de sacrés soucis, même en le mettant à jour dans sa dernière version !

-le "Atheros AR8121" qui ne me pose pas de problème !

Le soucis c'est que j'ai bien mis le 2ème à jour, mais le premier, impossible ! Si je le mets dans sa dernière version, j'ai des BSOD à répétition (dont des DRIVER_IRQL_NOT_LESS_OR_EQUAL, des NON_PAGE_IN_DEFAULT, des BSOD où je vois clairement le driver "athr.sys"), si je le met dans une version antérieure, pareil !

Et je suis sûr que c'est CE driver qui me fait des misères parce que depuis que je l'ai désactivé tout fonctionne parfaitement !

Après avoir écrit le 1er message du topic je revenais de chez le réparateur donc niveau RAM je pense que je suis bon.

Là je ne sais pas trop quoi faire ....

Je peux vous redonner un BSOD :

MI3381~1.DMP

Informations générales

Bug Check Code 0x1000007E

Bug Check String SYSTEM_THREAD_EXCEPTION_NOT_HANDLED_M

Paramètre 1 0xC0000006

Paramètre 3 0x8E2EC27E

Paramètre 3 0x8A51CBCC

Paramètre 4 0x8A51C8C8

Date du crash 19/11/2012 21:59

Architecture x86

Version majeure 15

Version mineure 6002

Nombre de processeurs 2

Taille du fichier dump 128 Ko

Source du crash

Source du crash athr.sys+36C61

Chemin C:\Windows\system32\athr.sys

Description Atheros Extensible Wireless LAN device driver

Version 7.7.0.449

Compagnie Atheros Communications, Inc.

Taille 1.15 Mo

Et tout un tas d'autres informations, avec à chaque fois athr.sys cité ...

Je sais que c'est ce driver, mais je ne sais pas comment réparer le problème ! Pourriez-vous m'aider ? Je vous remercie d'avance ! ;)

PS: j'arrive heureusement à accéder à internet grâce au tethering de mon téléphone et à la Wifi du PC de ma GF !

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour charon et merci pour ta réponse !

Est-ce qu'il faut que je désinstalle au préalable le driver qui me pose problème ? Parce que j'ai beau essayer de mettre à jour le périphérique avec ceux de la page que tu m'as indiqué, mais il me répète inlassablement que "ce périphérique est à jour blabla ..."

J'aurai bien essayé de mettre la version précédente, mais l'option est grisée ...

Partager ce message


Lien à poster
Partager sur d’autres sites

Coucou Charon et Mandorol,

Puis-je vous faire part d'une petite expérience ? Chez un de mes amis tous les portables se connectaient sans problème en wi-fi (wpa2), des portables xp, w7... mais pas le portable vista... en désespoir de cause j'ai installé le driver trouvé ici http://www.atheros.cz/ (différent de celui proposé par ma-config) et tout-à-coup tout a fonctionné. Je n'apporte pas de solution, car il s'agissait du driver AR5007EG, mais ne perdez pas confiance, il s'agit sûrement d'une broutille, mais il faut parfois avoir un peu de chance, et on ne peut toujours tout expliquer...

désinstaller le périphérique peut-être, et forcer un nouveau driver

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir tout le monde, et désolé de ne répondre que siiiiii tard mais j'ai enfin un peu de temps pour trifouiller la bête et risquer de ne pas avoir internet quelques temps !

 

J'ai pas mal recherché sur la toile et j'ai un peu peur de me lancer dans la désinstallation d'un driver, parce que 1) je ne l'ai jamais fait et 2) ça touche la wifi et c'est la seule façon pour moi d'avoir internet dans mon appart (et ouais, 600€/mois, mais pas foutu de mettre une sortie Ethernet, cherchez l'erreur ...)

 

Bref, j'ai continué à regarder un peu partout, et suis revenu sur ma-config, quand j'ai vu quelque chose :

mon driver (celui qui me pose problème) est le Atheros AR5B91 Wireless Network Adapter

Le driver que Ma-config indique (donc qui devrait être le même que celui du dessus ...) : Atheros Communications Inc. AR928X Wireless Network Adapter (PCI-Express) 

Les 2 sont différents ! Alors je ne m'y connais pas du tout en pilotes mais cela peut déjà jouer sur le fait que je ne trouve pas la solution !?
 
Donc là plutôt que de toucher à tout et risquer de faire une bêtise, je me suis demandé si upgrader mon PC en Windows 8 (actuellement sous Vista) pouvait regler ces problèmes de driver. Qu'en pensez-vous ? Ou alors un OS plus léger ?
 
Merci pour vos réponses !
M

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

×