Aller au contenu
BreakingBad

Besoin d'aide Install Ma-Config

Recommended Posts

Bonjour,

Suivant la documentation:

J'ai uploadé via FTP le SDK de base (hebergement mutualisé, cloud linux)

J'ai ajouté les droits d'ecriture sur le dossier plugin puis lancer samples/install.php (Avec IE et Mozilla, cela me renvoit sur une page blanche.)

Suite a cela, je retrouve dans le dossier plugin: les plugins en version 5. (Dans le doute j'y ai ajouté les version 6...)

Enfin, lorsque je lance test.php, la page ce charge mais sans le logo Ma-Config (croix rouge a la place.)

Je me suis dis je touche au but, pour ne pas m'embeter et gagner du temp, je vais integré test.php via une iframe afin de récuperer le header et footer de mon site.

Malheuresement si je fais cela, en plus du bug avec le logo, je me retrouve avec des petits carré a la place de nombreux caractère.

J'ai donc tenté une autre approche et récuperé le code dans test.php, puis integré celui-ci dans une de mes pages web sous Wordpress a l'aide de différent plugin PHP.

Mais j'ai des erreurs... les 2 premières ont été résolu, mais il me reste celle-ci:

Warning: include(../mcsdkbase.php) [function.include]: failed to open stream: No such file or directory in /home/ntsisrv/public_html/wp-content/plugins/php-snippets/snippets/test.snippet.php on line 12

Warning: include(../mcsdkbase.php) [function.include]: failed to open stream: No such file or directory in /home/ntsisrv/public_html/wp-content/plugins/php-snippets/snippets/test.snippet.php on line 12

Warning: include() [function.include]: Failed opening '../mcsdkbase.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/ntsisrv/public_html/wp-content/plugins/php-snippets/snippets/test.snippet.php on line 12

Fatal error: Class 'mcplugin' not found in /home/ntsisrv/public_html/wp-content/plugins/php-snippets/snippets/test.snippet.php on line 13

Pas de soucis coté licence.

J'ai un profil "système et réseaux" et non dévelloppeur, j'ai bien peur d'arriver au bout de mes compétances sur ce sujet !

Je dois passer a coté de quelque chose, en esperant qu'une ame charital puisse me venir en aide, afin que je puisse reussir cet integration qui me tiens a coeur !

Merci a ceux qui m'ont lu jusqu'ici.

Bonne journée a vous !

Yoann

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

dans le dossier sample vous devez modifier le fichier config.php. et modifier l'info $MCConfig['rootpath'] Vous devez ajouter l'url du dossier mcsdkbase avec le / a la fin. Indiquez aussi la licence dans le champ correspondant.

Pouvez vous aussi me donner l'url de votre site web?

Pour la version 6 je ne l'ai pas encore appliqué sur le SDK car les installeurs du plugin vont télécharger sur mon serveur. Je prévois en fait une grosse mise à jour mais ce n'est pas avant plusieurs mois

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci pour votre retour.

J'avais deja fait la modification pour la clé de licence, j'ai attendu d'avoir le message pour rentrer la clé... je suis ok de ce coté la.

Concernant l'URL, du dossier mcsdkbase:

Mon site se trouve a la racine de /public_html

Mcsdkbase est dans le dossier /public_html/wp-content/plugins/php-snippets/snippets

test.php a été renommé en test.snippet.php pour pouvoir "integrer" le code sur mon site.

J'ai testé toute sorte de combinaison pour $MCConfig['rootpath'] mais j'ai toujours la meme erreur.

Je ne dois pas avoir la bonne syntaxe avec ou sans / ou début ou a la fin, avec l'URL complete etc...

$MCConfig['rootpath']=''; /*/public_html/wp-content/plugins/php-snippets/snippets/*/

$MCConfig['rootpath']=''; /*public_html/wp-content/plugins/php-snippets/snippets*/

$MCConfig['rootpath']=''; /*http://............/..../....../*/

?

Partager ce message


Lien à poster
Partager sur d’autres sites

Il faut mettre cette syntaxe, il faut mettre l'url web et pas le chemin du dossier local.

$MCConfig['rootpath']='http:/***************/';

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci !!

A priori la synthaxe est bonne maintenant, j'ai essayé avec et sans le www.... meme erreur.

J'ai peur que ces codes d'erreurs soient lié a l'integration du code php dans wordpress !?

Car lorsque je charge directement test.php cela fonctionne deja beaucoup mieux...

Par contre en lancant la detection j'ai un nouveau msg pour la licence...

Je n'utilise pas de sous domaine (http://www.ntsi-group.com/wp-content/plugins/php-snippets/snippets/samples/test.snippet.php)"

Je vais m'acharner encore un peu, et recommencerais au propre au cas ou...

PS: Merci pour votre disponibilité ! Meme le dimanche ! Je me sens moi seul ^^ !

Yoann

Partager ce message


Lien à poster
Partager sur d’autres sites

Re,

La page test fonctionne maintenant correctement:

http://www.ntsi-grou...amples/test.php

L'integration dans une iframe génere un bug d'affichage uniquement sur la première

http://www.ntsi-grou...drivers-iframe/

J'ai testé d'autres iframe sur plusieurs sites, seul cette page pause problème.

En fait si il n'y avait pas d'accent tout serait niquel !

Concernant l'execution du code directement dans ma page wordpress:

J'ai testé différent plugin, je pense en avoir trouvé un qui fonctionne, en revanche, je suis obliger de renommer la page test et de la déplacé dans le repertoire parent.

J'ai donc déplacé celle-ci avec la page config.php, puis modifier dans la page test la ligne suivante:

define('mc_root_path','http://ntsi-group.co...CTORY_SEPARATOR)

Je pense avoir avancer car j'ai maintenant les erreurs suivantes:

Warning: include() [function.include]: http:// wrapper is disabled in the server configuration by allow_url_include=0 in /home/ntsisrv/public_html/wp-content/plugins/php-snippets/snippets/test.snippet.php on line 12

Fatal error: Class 'mcplugin' not found in /home/ntsisrv/public_html/wp-content/plugins/php-snippets/snippets/test.snippet.php on line 13

Je vais donc voir pour activé ce fameux wrapper sur mon serveur....

J'aurais 2 petites questions:

- Auriez-vous une idée pour le bug d'affichage lorsque je passe par une iframe ?

- Si non, suis-je sur la bonne voix avec ce fameux wrapper ou est-ce pire que la dernière fois ?

J'espère ne pas abuser de votre gentilesse !

Encore merci !

Yoann

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour pour que l'iframe marche dans le fichier test.php ajouter cette ligne après la ligne setlicence

$plug->set_charset("UTF-8");

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

×