Aller au contenu
robot

Mise à jour automatique du plugin

Publications recommandées

Une version majeure vient d'être mise en ligne (5.2.0.0).

Désormais le plugin se met à jour automatiquement. Il utilise le système de mise à jour déjà présent pour télécharger le dernier installeur si une nouvelle version est disponible.

Quand l'installeur se lance, il ferme tous les navigateurs où le plugin est chargé en mémoire après approbation de l'utilisateur.

La mise à jour automatique du plugin peut être désactivée dans le centre de paramétrage. Dans ce cas si une nouvelle version est disponible l'utilisateur, par le biais d'une fenêtre de choix, sera invité à installer le nouveau plugin ou à détecter avec le plugin existant comme auparavant.

La mise à jour automatique du plugin n'est pas disponible pour Linux et pour les anciens systèmes.

J'ai revu le système de vérification de versions pour les navigateurs NPAPI (Firefox, Chrome, Opera, Safari...). Il ne charge plus le plugin en mémoire pour vérifier la version, ce qui devrait améliorer l'utilisation du site dans les cas où la mise à jour automatique du plugin n'est pas activée.

J'ai mis à jour la version du plugin pour les anciens systèmes en version 5.2.0.0 pour l'aligner sur les autres plugins. Le plugin Linux a aussi été mis à jour. Windows 98 et ME ne sont plus du tout supportés.

Lorsque vous êtes connecté, quand une configuration conservée sur le site n'est pas à jour, le site affiche un avertissement pour signaler que la configuration n'est pas à jour. Si la configuration avait été générée par le plugin Linux ou celui pour les anciens systèmes, cet avertissement pouvait apparaître même il n'y avait pas de nouvelle version. Ce bug a été corrigé.

Partager cette publication


Lien à poster
Partager sur d’autres sites

dis moi charon, tu as supprimé le support 98 pour te simplifier la vie ou est-ce que ça devenait une obligation pour pouvoir avancer (par exemple nouveau langage incompatible) vu que je ne suis pas pro en dev/prog je me le demande ????????

Partager cette publication


Lien à poster
Partager sur d’autres sites

J'ai modifié le système de vérification de version. Avec les plugin NPAPI, il ne charge plus le plugin pour vérifier la version. Ca devrait éviter pas mal d'ennuis avec des installations foireuses car le plugin est chargé.

Le problème c'est que l'ancien plugin ne marchait plus. J'ai donc du sortir une nouvelle version. Sauf qu'entre temps j'ai passé le plugin en unicode pour pouvoir gérer plus de langues. Mais Windows 98 et ME ont un support extrêmement limité de l'unicode. C'était tout simplement impossible de le faire marcher sur 98 et ME.

Cependant je n'ai pas essayé mais je pense qu'il est quand même possible de faire marcher le vieux plugin(la version 4.1.0.3) sur 98 en utilisant une détection hors ligne. Je mettrai un tuto sur le forum mais officiellement Windows 98 et ME ne sont plus du tout supportés.

Partager cette publication


Lien à poster
Partager sur d’autres sites

Qui me parle ? :ph34r:

Perso j'ai arrêté le support des 9x (et me) y a six mois. C'était pour des prob d'installation en fait. J'aurais pu continuer mais, ca valait pas le coup.

Mais bon tu sait bien qu'on est pas comparable moi ce sont des prog de gestion, moins de dépendance avec les api systèmes de win.

Partager cette publication


Lien à poster
Partager sur d’autres sites

Qui me parle ? :ph34r:

Perso j'ai arrêté le support des 9x (et me) y a six mois. C'était pour des prob d'installation en fait. J'aurais pu continuer mais, ca valait pas le coup.

Mais bon tu sait bien qu'on est pas comparable moi ce sont des prog de gestion, moins de dépendance avec les api systèmes de win.

Oui il doit même pas y avoir 1% de 98 et ME. Comme le dit mon modérateur Microsoft ne supporte plus Windows 98 et ME depuis un moment.De plus ni Visual studio 2008 ou 2010 ne le supporte. Toutes les nouvelles applications sont automatiquement incompatibles.

Partager cette publication


Lien à poster
Partager sur d’autres sites

MS a laché le support depuis longtemps! lol

Si je ne me trompe pas le support XP doit bientôt cesser aussi du côté de XP mais à mon avis il restera dans le parc bien plus longtemps encore que 98 ...

Partager cette publication


Lien à poster
Partager sur d’autres sites

j'ai XP et j'ai utilisé ma config pour mettre à jour mes pilotes

le logiciel m'affiche qu'une nouvelle version de plugin version 5.2.1 build 0 est en ligne

quelqu'un pourrait il m'aider en m'expliquant qu'est ce que je dois faire?

d'avance merci pour toute aide

chris

Partager cette publication


Lien à poster
Partager sur d’autres sites

Bonjour,

Tu cliques sur démarrer la detection, cliques sur installation manuelle ,tu installes le plugin et tu cliquer sur le raccourci démarrer la détection sur le bureau.

Partager cette publication


Lien à poster
Partager sur d’autres sites
Invité
Vous postez un commentaire en tant qu’invité. Si vous avez un compte, merci de vous connecter.
Répondre à ce sujet...

×   Collé en tant que texte riche.   Changer pour un collage en texte brut

  Seules 75 émoticônes sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher en tant que lien à la place

×   Votre contenu précédent a été restauré.   Vider l'éditeur

×   You cannot paste images directly. Upload or insert images from URL.


×