Jump to content
ChtiGG

[IDEES] Pour améliorer le site

Recommended Posts

Salut à tous,

Nouveau petit sujet pour aider notre administrateur préféré à toujours améliorer ma-config.com :)

J'ai eu une idée (eh oui ça m'arrive) :D

Lors de la détection, souvent la toute première, après l'install du plugin, on est confronté à un "timeout".

On avait déjà beaucoup cherché ensemble Charon si tu te souviens mais ça arrive encore.

Donc l'idée, pour éviter de faire fuir les nouveaux utilisateurs, ce serait qu'un bouton "relancer la détection" apparaisse sous la mention "timeout".

Ca évite dans ce cas de devoir redérouler le menu par l'onglet "démarrer la détection" et de cliquer de nouveau sur le bouton vert "démarrer la détection".

Qu'en penses tu ? :unsure:

Qu'en pensez vous les autres ? :unsure:

Share this post


Link to post
Share on other sites

Bonjour,

Tu parles d'un autre bug lié à la vérification des mises à jours, je crois. En fait depuis la version 3 la détection s'exécute dans un service système et il communique avec le navigateur web par un plugin. Quand la communication est coupée ou que le service ne répond plus(le service plante par exemple) ça peut afficher le message de timeout.

Rajouter un lien pour redetecter ne me plait pas trop, ça ne corrige pas le problème pour autant.

Si tu arrives à reproduire le problème il faudrait que tu regardes le contenu du dossier logs de ma-config.com ca génère un dump si le service plante. Après quand le timeout se produit? Au tout début de la détection? Le problème est peut être autre. C'est peut être un problème d'initialisation de la communication. Si tu arrives à reproduire le problème je veux bien essayer de le corriger.

Share this post


Link to post
Share on other sites

Bonsoir a tous bonsoir ChtiGG vous savez si le plugin déconne et qui faut le réinitialiser (autrement dit relancer une détection ) il suffirait juste d appuyer sur F5

bonne continuation a tous

Share this post


Link to post
Share on other sites

De plus si je mettais un lien les gens pourraient cliquer pendant la détection le navigateur pourrait ne pas apprécier.

Par contre j'ai cherché dans le forum je n'ai pas trouvé beaucoup de gens qui se sont plaints de ce problème récemment. Tu as pu constater le bug toi même? Ensuite l'ennui, peu de gens m'avertissent quand ils ont un bug. Et quand ils postent 90% des fois ils ne répondent plus et renvoient jamais les logs....

Share this post


Link to post
Share on other sites

De plus si je mettais un lien les gens pourraient cliquer pendant la détection le navigateur pourrait ne pas apprécier.

En fait il faudrait coder le truc pour que le bouton relancer la détection apparaisse au moment où le timeout se produit.

J'ai eu le souci sur un PC neuf Asus ce matin, d'où cette demande. Ca a planté vers la fin de la détection.

J'ai aussi créé ce topic spécialement pour tous ceux qui constatent des bugs et qui ont "la flemme" d'en créer un, pour des bricoles selon eux car en effet lors du timeout il suivi de cliquer sur relancer la détection dans la seconde qui suit et aucun problème, la seconde fois ça passe comme papa dans maman :D

Share this post


Link to post
Share on other sites

En fait il faudrait coder le truc pour que le bouton relancer la détection apparaisse au moment où le timeout se produit.

Ca devrait être géré au niveau du plugin et aussi dans l'interface du plugin. Faire un lien n'est pas trivial. Ca compliquerait beaucoup juste pour cacher un bug qui est toujours là

J'ai eu le souci sur un PC neuf Asus ce matin, d'où cette demande. Ca a planté vers la fin de la détection.

Envoie moi les logs dans c:\program data\ma-config.com\logs tu dois avoir un dump. Sinon on peut regarder ensemble le problème.

J'ai aussi créé ce topic spécialement pour tous ceux qui constatent des bugs et qui ont "la flemme" d'en créer un, pour des bricoles selon eux car en effet lors du timeout il suivi de cliquer sur relancer la détection dans la seconde qui suit et aucun problème, la seconde fois ça passe comme papa dans maman :D

Je peux épingler ton topic mais je dois éditer ton premier message pour explique ce qu'il faut faire ou je recrée un autre topic épinglé pour ce problème. Je ne peux pas joindre les deux topics, Invision va trier les messages par date. Le premier message va se retrouver en bas du coup.

Share this post


Link to post
Share on other sites

Tu peux éditer mon premier post sans souci ;)

Voici les logs en pièce jointe (oups ... Erreur Vous n'avez pas la permission d'envoyer ce type de fichier ...)

Je te l'envoi par mail.

Je ne serai plus dispo avant demain.

Bonne après midi.

Share this post


Link to post
Share on other sites

J'ai crée un autre topic et épingler celui là c'était deux choses différentes.

Par contre les logs il y avait rien aucun dump. Il faudrait que tu actives le debug dans les parametres avant et que tu reproduises le probleme . Ferme bien le navigateur.là tu m'envoies les log.

Share this post


Link to post
Share on other sites

Dès que je refais une install toute fraiche je penserai à activer le débug.

Il n'est pas possible de l'activer par défaut ?

Share this post


Link to post
Share on other sites

C'est ce que je me disais en fait je vais surement l'activer par defaut pour la prochaine version et aussi augmenter la taille maximale des logs

Share this post


Link to post
Share on other sites

Bonjour charon, serait il possible de renommer l'executable "demarrer la detection" en "MaConfig demarrer la detection" par exemple car sur Win8 si l'executable n'est pas epinglé au startscreen on a plutot tendance a le rechercher en tapant "maconfig" plutot que "demarrer la detection". On peut le faire manuellement mais a chaque mise a jour il faut renouveller la procedure ...

Share this post


Link to post
Share on other sites

Bonjour charon

j'ai une idée d'joute autre service sur Ma-Config:

 

Un service qui donne au membre qui on plusieurs détections enregistrées  sur ces espaces membres, de comparer deux détection ou plus,

 

Pour,  enfin afficher selon un ou plusieurs critères de choix, la liste de plus performant vers le moins.

 

C'est exactement comme www.prixdunet.com/

 

Par exemple, J'ai deux configurations, et j'aime savoir qu'elle est le plus de performances ( selon, fréquence processeur, mémoire RAM (capacité et fréquence), carte graphique ...) 

 

avec ça, Ma-Config, devient le comparateur N°1 sur le web des détections ( soit occasions ou nouvelles) ;)

 

J'espère que cet idée sera un parmi les innovations sur Ma-Config 

 

Bonne journée à tous

Share this post


Link to post
Share on other sites

Bonjour DreamTronic,

merci pour ton message :)

Les noms de configurations sont utilisés comme index dans la base pour identifier les machines de façon unique pour un utilisateur. Ca n'a pas changé depuis pour maintenir la compatibilité.

Le nom correspond au nom de l'ordinateur dans Windows. Si vous changez ce nom dans Windows et que vous redétectez, vous aurez le nom voulu

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...