Jump to content

Version 5: support Linux !!


robot
 Share

Recommended Posts

<div>Bonjour amis configuriens ;)</div><div><br /></div><div>Je viens de déployer ce matin la version 5 du <em>plug-in </em>Ma-Config.com. Ma-Config est donc prêt pour les fêtes de Noël :). La grande nouveauté de cette version est le support de Linux. Je n'ai pas voulu créer une version spécifique pour Linux. La version Linux partage donc la même architecture que celle pour Windows rendant ainsi le <em>plug-in </em>multiplate-forme. La plupart des modules Linux sont multiplate-forme et partagent une grande partie du code avec les modules Windows correspondants.</div><div> </div><div>Cependant il est important de noter que le <em>plug-in </em>Linux intègre un nombre moindre de modules comparé à sa version Windows. Le mode <em><strong>réseau</strong></em>, le service <em><strong>MesDrivers</strong></em> et la <em><strong>détection</strong> <strong>hors-ligne</strong></em> ne sont pas non plus disponibles. Cependant la <em><strong>configuration résumée</strong></em> est suffisamment complète pour fonctionner avec les SDK destinés aux webmasters. Ces SDK ont été mis à jour et supportent eux aussi, désormais Linux. Le site PC Inpact vient d'ailleurs de le mettre en ligne sur son forum (merci à Lilo et Pierre Alain ;) ). Je rappelle que les SDK sont gratuits, sans publicité et disponibles pour tout site doté d'un nom de domaine.</div><div><br /></div><div>Le changement de code dans la version 5 est très important. Cette évolution a permis de le purifier. Les bénéfices sont donc aussi présents dans la version Windows. La version 5 était prévue depuis un bon moment. La version 4 constituait d'ailleurs une étape principale de cette évolution. Elle a permis d'intégrer un nouveau format XML portable pour les configurations.</div><div><br /></div><div>Pour la version Linux, le <em>plug-in </em>est disponible sous forme de paquets Debian et RPM pour 32 et 64 bits. J'ai compilé le <em>plug-in </em>pour LSB (Linux standard Base) afin de maximiser la compatibilité entre les distributions. J'ai testé le <em>plug-in</em> sur les dernières distributions Ubuntu, Fedora, Debian, Open Suse, Mandriva. Le <em>plug-in </em>a été testé avec succès sous Linux sur les navigateurs Firefox / Chromium / Google Chrome. Il échoue cependant sur plusieurs navigateurs comme Midori ou Opera du fait de la mauvaise implémentation de la norme NPAPI dans ces navigateurs. On notera enfin que Ma-Config.com fonctionne sur l'ensemble des navigateurs Windows (y compris la version Windows d'Opera). </div><div><br /></div><div>Je rappelle que c'est une première version du moteur Linux, le <em>plug-in </em>est donc destiné à évoluer. Il est aussi possible qu'il y ait des problèmes de dépendance avec certaines distributions: je ne peux pas tester les centaines de versions Linux :D  A vous de faire remonter ces informations pour leur prise en compte  progressive.</div><div> </div><div> </div><div>Le webmaster et toute l'équipe de Ma-Config.com vous souhaitent de joyeuses fêtes. Pensez à venir sur notre site quand vous aurez reçu vos nouveaux PC ;)</div><div><br /></div><div>NB: un exemple de configuration Linux est disponible sur <a href="fr/configurationpubliee/108413-0,resume.html" target="_blank">ce lien</a></div><div>Merci à <strong>Fréderic Lepied</strong> ancien CTO de Mandriva pour ses conseils ;) </div>

Link to comment
Share on other sites

<div>Bonjour amis configuriens ;)</div><div><br /></div><div>Je viens de déployer ce matin la version 5 du <em>plug-in </em>Ma-Config.com. Ma-Config est donc prêt pour les fêtes de Noël :). La grande nouveauté de cette version est le support de Linux. Je n'ai pas voulu créer une version spécifique pour Linux. La version Linux partage donc la même architecture que celle pour Windows rendant ainsi le <em>plug-in </em>multiplate-forme. La plupart des modules Linux sont multiplate-forme et partagent une grande partie du code avec les modules Windows correspondants.</div><div> </div><div>Cependant il est important de noter que le <em>plug-in </em>Linux intègre un nombre moindre de modules comparé à sa version Windows. Le mode <em><strong>réseau</strong></em>, le service <em><strong>MesDrivers</strong></em> et la <em><strong>détection</strong> <strong>hors-ligne</strong></em> ne sont pas non plus disponibles. Cependant la <em><strong>configuration résumée</strong></em> est suffisamment complète pour fonctionner avec les SDK destinés aux webmasters. Ces SDK ont été mis à jour et supportent eux aussi, désormais Linux. Le site PC Inpact vient d'ailleurs de le mettre en ligne sur son forum (merci à Lilo et Pierre Alain ;) ). Je rappelle que les SDK sont gratuits, sans publicité et disponibles pour tout site doté d'un nom de domaine.</div><div><br /></div><div>Le changement de code dans la version 5 est très important. Cette évolution a permis de le purifier. Les bénéfices sont donc aussi présents dans la version Windows. La version 5 était prévue depuis un bon moment. La version 4 constituait d'ailleurs une étape principale de cette évolution. Elle a permis d'intégrer un nouveau format XML portable pour les configurations.</div><div><br /></div><div>Pour la version Linux, le <em>plug-in </em>est disponible sous forme de paquets Debian et RPM pour 32 et 64 bits. J'ai compilé le <em>plug-in </em>pour LSB (Linux standard Base) afin de maximiser la compatibilité entre les distributions. J'ai testé le <em>plug-in</em> sur les dernières distributions Ubuntu, Fedora, Debian, Open Suse, Mandriva. Le <em>plug-in </em>a été testé avec succès sous Linux sur les navigateurs Firefox / Chromium / Google Chrome. Il échoue cependant sur plusieurs navigateurs comme Midori ou Opera du fait de la mauvaise implémentation de la norme NPAPI dans ces navigateurs. On notera enfin que Ma-Config.com fonctionne sur l'ensemble des navigateurs Windows (y compris la version Windows d'Opera). </div><div><br /></div><div>Je rappelle que c'est une première version du moteur Linux, le plug-in est donc destiné à évoluer. Il est aussi possible qu'il y ait des problèmes de dépendance avec certaines distributions: je ne peux pas tester les centaines de versions Linux :D  A vous de faire remonter ces informations pour leur prise en compte  progressive.</div><div> </div><div> </div><div>Le webmaster et toute l'équipe de Ma-Config.com vous souhaitent de joyeuses fêtes. Pensez à venir sur notre site quand vous aurez reçu vos nouveaux PC ;)</div><div><br /></div><div>NB: un exemple de configuration Linux est disponible sur <a href="http://www.ma-config.com/fr/configurationpubliee/108413-0,resume.html" target="_blank">ce lien</a></div><div>Merci à <strong>Fréderic Lepied</strong> ancien CTO de Mandriva pour ses conseils ;) </div>

Salutation !

Pour ma part , je suis très déçu de cette V5 , je m'attendais à mieux ... en effet , aucun apport pour les usagers windows ,

uniquement pour les linuxiens qui au passage se contrefichent pour les plus sages de la version de leurs drivers.

Plusieurs mois d'attente pour une version qui ne m'apporte rien , une migration de l'usage vers une minorité d'usager

j'ai du mal à y croire ... le partenariat avec MS semble désormais à oublier et j'en suis triste.

Dans l'attente d'une "REVOLUTION" pour l'usager windows ?

Link to comment
Share on other sites

Salutation !

Pour ma part , je suis très déçu de cette V5 , je m'attendais à mieux ... en effet , aucun apport pour les usagers windows ,

uniquement pour les linuxiens qui au passage se contrefichent pour les plus sages de la version de leurs drivers.

Plusieurs mois d'attente pour une version qui ne m'apporte rien , une migration de l'usage vers une minorité d'usager

j'ai du mal à y croire ... le partenariat avec MS semble désormais à oublier et j'en suis triste.

Dans l'attente d'une "REVOLUTION" pour l'usager windows ?

Bonjour Hyperia, les versions majeures sur Ma-Config.com apportent rarement des nouveautés concrètes pour l'utilisateur. Les changements internes sur l'architecture sont toujours effectués sur les versions majeures. C'est toujours du travail de fond donc ça prend du temps.

Je prévois des features Windows only par la suite. Pour la révolution tu en attends beaucoup :D

Libre à toi de faire des propositions sur le forum "bugs et améliorations du site" il est aussi là pour ça. Je te dirai si c'est viable ou pas comme idées :smileJap:

je comprend quand même ta réaction je comptais aussi supporter OSX mais comme ça prendrait trop de temps supplémentaire je préfère me focaliser sur des fonctionnalités plus concrètes.

Link to comment
Share on other sites

Bonjour Hyperia, les versions majeures sur Ma-Config.com apportent rarement des nouveautés concrètes pour l'utilisateur. Les changements internes sur l'architecture sont toujours effectués sur les versions majeures. C'est toujours du travail de fond donc ça prend du temps.

Je prévois des features Windows only par la suite. Pour la révolution tu en attends beaucoup :D

Libre à toi de faire des propositions le forum "bugs et améliorations du site" il est aussi là pour ça. Je te dirai si c'est viable ou pas comme idées :smileJap:

je comprend quand même ta réaction je comptais aussi supporter OSX mais comme ça prendrait trop de temps supplémentaire je préfère me focaliser sur des fonctionnalités plus concrètes.

Hum ! ok !

On ne connait pas linux pour son support driver rapide , pour OSX je n'en sais rien ,

c'est en ça que je trouve également dommage cette V5 , beaucoup de travail ,

beaucoup de temps pour un résultat qui je l'espère sera à la mesure de

ton travail , même si je n'en suis pas convaincu :unsure:

Je n'ai plus qu'une question : Des infos sur la future maj majeure win only ?

Que cela prenne du temps , je comprends parfaitement et je ne trouve même rien à dire la dessus :smileJap:

Un support OSX ? tu comptes trouver finance dans l'app store ?

Link to comment
Share on other sites

Pour OSX c'est remis pour je ne sais pas quand et j'ai quasiment pas de demandes, c'est loin derrière ma liste de priorité. Pour Linux le service de MesDrivers ne marche pas. Linux c'est 1% d'utilisateurs ce n'était donc pas ma motivation principale. Je propose un kit depuis quelque temps destiné aux webmasters pour qu'ils puissent intégrer Ma-Config dans leur forum. Seulement beaucoup de webmasters rechignent à installer des technologies non portables. C'est con mais c'est comme ça :( Le support Linux a été fait dans cet unique but.

Pour la maj windows elle n'est pas majeure. J'introduis une suite d'évolutions. Pour donner un exemple Vista était une version majeure en terme d'architecture et Windows 7 s'est contenté d'ajouter quelques trucs. pour la majorité des gens c'est Windows 7 la version majeure.

Je ne peux pas te dire quand ça sortira je donne jamais cette date. Il n'y a pas une fonctionnalité mais plusieurs à intégrer. C'est sur que ça ne prendra pas autant de temps.

La première chose sur la liste ne va pas t'intéresser. C'est le passage en UTF8 sur le site pour intégrer de nouvelles langues comme le russe ,le chinois mais aussi l'italien. Mes traducteurs s'impatientent. :smileJap:

Link to comment
Share on other sites

Pour OSX c'est remis pour je ne sais pas quand et j'ai quasiment pas de demandes, c'est loin derrière ma liste de priorité. Pour Linux le service de MesDrivers ne marche pas. Linux c'est 1% d'utilisateurs ce n'était donc pas ma motivation principale. Je propose un kit depuis quelque temps destiné aux webmasters pour qu'ils puissent intégrer Ma-Config dans leur forum. Seulement beaucoup de webmasters rechignent à installer des technologies non portables. C'est con mais c'est comme ça :( Le support Linux a été fait dans cet unique but.

Pour la maj windows elle n'est pas majeure. J'introduis une suite d'évolutions. Pour donner un exemple Vista était une version majeure en terme d'architecture et Windows 7 s'est contenté d'ajouter quelques trucs. pour la majorité des gens c'est Windows 7 la version majeure.

Je ne peux pas te dire quand ça sortira je donne jamais cette date. Il n'y a pas une fonctionnalité mais plusieurs à intégrer. C'est sur que ça ne prendra pas autant de temps.

La première chose sur la liste ne va pas t'intéresser. C'est le passage en UTF8 sur le site pour intégrer de nouvelles langues comme le russe ,le chinois mais aussi l'italien. Mes traducteurs s'impatientent. :smileJap:

Effectivement , je n'osai pas te parler de % au risque de passer pour un fanboy MS mais en fin de compte , je vois que toi aussi tu connais les chiffres ...

Effectivement , l'UTF8 ne m’intéressera pas , tu as raison , je suis trop peu compétant dans le domaine de la traduction

Effectivement , quand je parle de "REVOLUTION" , je n'en espère pas tant , c'est juste pour tabler avec Free :Forum25:

Satisfait de voir que tu restes à l'écoute ! :Alcooliques04:

Link to comment
Share on other sites

d'ailleurs je l'attends cette nouvelle freebox j'ai effectué ma migration :)

Pour Microsoft je suis considéré comme le pire des fanboy MS et je le cache pas :D

One

Two

mais je suppose que tu à déjà lu ça :)

si besoin est , n'hésites pas à me faire signe pour un éventuel rappel de vaccination A.N.T.I.M.A.C.T.U.X*

( plusieurs millions de morts à travers le monde et aucune prévention contre les dangers de cette saloperie* )

:D;)

Link to comment
Share on other sites

  • 3 weeks later...
  • 3 weeks later...

Bonjour,

Sous Ubuntu (karmic, 9.10, stable, à jour), j'essaie d'installer le plugin (deb 32-bit, pour l'utiliser depuis Firefox) :

- Une première fois, j'essaie l'installation en cliquant sur l'icône démarrer la détection qui me propose de télécharger le .deb (ou de l'installer via le gestionnaire de paquets debian). Je choisi installer directement. Le .deb se télécharge bien, le gestionnaire de paquets debian installe tout bien aussi (20 dépendances à satisfaire). Une fois l'installation faite, je relance Firefox pour lancer la détection : "Licence du plugin invalide". Bon, ok.

Je vais voir dans Synaptic : ma-config.com est bien installé, mais taille = 0 octet... !? Ha, problème. Je désinstalle le tout (purge, même).

- Une deuxième fois, je télécharge le .deb, et l'installe à la main, depuis une console, via un

$ sudo dpkg -i MaConfig_Linux_5_1_0_0.deb

qui n'a pas marché tout de suite (dépendance on satisfaite : lsb)

$ sudo apt-get install lsb

qui n'a pas marché de suite non plus (erreur : essayez apt-get -f install <sans nom de paquet ensuite>)

$ sudo apt-get -f install

qui m'a installé toutes les dépendances nécessaires

enfin un :

$ sudo dpkg -i MaConfig_Linux_5_1_0_0.deb

fonctionne. Tout est installé

Je relance Firefox, je réessaie la détection : même erreur "Licence du plugin invalide". Je retourne voir dans Synaptic : ma-config.com (5.1.0.0) taille=0 -- bon, j'insiste pas plus loin, ça veut pas :\

Voilà, je passe les infos.

J'peux rien faire de plus, là.

-----

$ uname -a

Linux ubuntu 2.6.31-22-generic #71-Ubuntu SMP Thu Jan 6 22:47:22 UTC 2011 i686 GNU/Linux

Config (du vieux coucou) :

Asus A7N8X-X

AMD Athlon XP 2200+

2Go RAM

ATI Radeon 9250 (128Mo)

Link to comment
Share on other sites

Bonjour je vais essayer d'installer quand j'aurai le temps.

Licence plugin invalide, ça doit être le moteur de cryptage qui ne charge pas.

Si tu vas dans le dossier /usr/lib/ma-config après installation tape ldd libmccrypt.so.

Dis moi ce qu'il affiche.

Il n'y a pas que lsb comme dépendances je te les donne:

lsb (>= 3.2), libsqlite3-0, libusb-0.1-4, libxml2, libxslt1.1,libpciaccess0,libglib2.0-0,libx86-1

tu peux aussi regarder le dossier /usr/lib/ma-config/data/logs

Il doit y avoir des détails dans les logs.

Link to comment
Share on other sites

  • 5 years later...
Guest Invité

Je fais mes recherches mais ça serait bien de rendre plus accessible aux utilisateurs linux le téléchargement des drivers windows. Je comprends bien l'absence des drivers linux bien sûr, mais dans le cas d'une installation dualboot où certains drivers sont manquants, j'avoue que ça serait pratique de pouvoir avoir les DL en même temps que le résumé de la config.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...