Aller au contenu
eric0279

[Réglé] Bug Mod ma-config phpbb3

Publications recommandées

Salut charon,

je ne savais pas où poster ceci donc excuse moi...

j'aurais plus de chance d'avoir du support ici je pense...

[phpBB Debug] PHP Notice: in file /ma-config/MCSDKPHPBB3.php on line 27: Undefined index: maconfig_licence

[phpBB Debug] PHP Notice: in file /ma-config/MCSDKForum.php on line 55: Undefined variable: custominput

[phpBB Debug] PHP Notice: in file /ma-config/MCSDKForum.php on line 65: Undefined variable: custominput

[phpBB Debug] PHP Notice: in file /adm/index.php on line 287: Undefined offset: 2

[phpBB Debug] PHP Notice: in file /adm/index.php on line 287: Undefined offset: 2

[phpBB Debug] PHP Notice: in file /adm/index.php on line 287: Undefined offset: 2

[phpBB Debug] PHP Notice: in file /includes/acp/acp_maconfig.php on line 130: Undefined index: maconfig_licence

Le undefined Offset n'arrive qu'avec ton Mod....

Sinon, un petit bug dans ton code html je suppose :

http://img693.imageshack.us/i/maconfig.jpg

Le debug est activé pour afficher les requêtes SQL etc...

Merci pour la correction

Cordialement

Partager cette publication


Lien à poster
Partager sur d’autres sites

Bonjour,

c'est ton fichier php.ini qui est mal paramétré sur le serveur. error_reporting doit être sur E_ALL il faut le mettre sur E_ERROR| E_WARNING | E_PARSE

Ceci dit je corrige les warnings ils devrait pas y être. pour le design déformé ca vient de l'affichage des debugs

Partager cette publication


Lien à poster
Partager sur d’autres sites

C'est en ligne. Les warning ont tous été corrigés.

Sinon si ca affiche çà sur ton forum c'est que tu as mis debug à true dans le fichier config.php du forum. Il ne faut pas mettre cette option sur un forum en production.

Partager cette publication


Lien à poster
Partager sur d’autres sites

Je précise bien :

Le debug est activé pour afficher les requêtes SQL etc

ou connait tu un mod qui affichera les détails sans activer le debug ? car je n'en ai pas vu....

Le php.ini en local, cela ne me pose pas de problème mais lorsque le forum sera en production, je n'y aurais pas accès à ce fichier...

Merci à toi, je vais tester.

Last edited by charon777 on Sat Aug 28, 2010 8:05 am, edited 4 times in total.
tu l'a mis à jour où car tu semble ne pas l'avoir fait sur phpbb.com

Partager cette publication


Lien à poster
Partager sur d’autres sites

Merci.

Mise à jour faite, dans l'ACP, plus rien ne s'affiche juste une notice :

[phpBB Debug] PHP Notice: in file /ma-config/MCSDKPHPBB3.php on line 44: Undefined index: maconfig_licence

Aucune licence n'a été faite étant en local, je ne sais pas si c'est lié ?

Partager cette publication


Lien à poster
Partager sur d’autres sites

Tu utilises quel navigateur web?

Il faut que tu ailles dans l'admin de phpbb3. dans les options de profil personnalises dans user et groupes.dans l'option mconfiguration en cliquant sur les infos détailles il faut que tu augmentes le nombre de colonnes à 80.

Après C'est une option interne au mod il vaudrait mieux désactiver l'affichage dans le profil. Mais apparemment l'option pour désactiver les options de profils ne marche pas....

Partager cette publication


Lien à poster
Partager sur d’autres sites

Bonjour,

Je ne reproduis pas ton bug. tu parles bien de l'onglet profil dans le panneau de contrôle utilisateur?

Dans l'admin onglet utilisateurs et groupes:champ de profil personnalisés.va sur les options spécifiques au profil.

Largeurs de ligne tu mets 5

colonnes:80

nombre minimum de caractères:0

nombre maximum de caractères:1000

Tu reviens options basiques et sauvegarder.

Partager cette publication


Lien à poster
Partager sur d’autres sites

Dans l'admin onglet utilisateurs et groupes:champ de profil personnalisés, édition de mcconfiguration >> Options particulières du type de profil :

Options particulières du type de profil

Taille de la zone de saisie: 80

Nombre minimum de caractères: 0

Nombre maximum de caractères: 1000

Validation du champ: N'importe quel caractère

Le problème survient quand on est dans Panneau de l’utilisateur > Profil

Partager cette publication


Lien à poster
Partager sur d’autres sites

Dans l'admin onglet utilisateurs et groupes:champ de profil personnalisés, édition de mcconfiguration >> Options particulières du type de profil :

Le problème survient quand on est dans Panneau de l’utilisateur > Profil

Le type de champ c'est bien zone de texte chez toi?

Partager cette publication


Lien à poster
Partager sur d’autres sites

Le mod ma-config pour PHPBB3 utilise un champ personnalisé pour mettre la configuration en html. Normalement il doit y avoir une option pour cacher les champs personnalisés du profil.

Partager cette publication


Lien à poster
Partager sur d’autres sites

non c'est pas réglé, j'ai détecter la configuration et dans la case ci-dessus, il y a :

<a style='color: #718a96;' href='#' onclick="window.open('ma-config/mcsdkphpbb3print.php?action=print&idm=2','_blank','width=600,height=800,scrollbars=yes');return false;">afficher</a>

Partager cette publication


Lien à poster
Partager sur d’autres sites

J'ai désinstallé le mod mais dans le profil, il reste encore :

Configuration matérielle:

afficher

comment l'enlever stp ?

edit: j'ai trouvé, supprimer le champ de profil personnalisé.

re edit:

j'ai eu droit à l'erreur suivant en naviguant sur le forum:

Une erreur générale a été rencontrée: General Error

» SQL ERROR [ mysqli ]

Table 'core8_webpsell.profile_maconfig' doesn't exist [1146]

SQL

SHOW CREATE TABLE profile_maconfig

BACKTRACE

FILE: includes/db/mysqli.php

LINE: 163

CALL: dbal->sql_error()

FILE: includes/acp/acp_database.php

LINE: 920

CALL: dbal_mysqli->sql_query()

FILE: includes/acp/acp_database.php

LINE: 731

CALL: mysql_extractor->new_write_table()

FILE: includes/functions_backup_scheduler.php

LINE: 144

CALL: mysql_extractor->write_table()

FILE:

LINE:

CALL: scheduled_backup()

Passe de bonne fêtes !

Partager cette publication


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Se connecter dès maintenant

×